S5700S-28P-LI-AC华为三层交换机与TL-ER6120普联路由器的简单组网-折腾笔记

由于有点需求,需要搭建一个奇怪的网络作为过渡网络,大概拓扑结构如下图。

由于之前在学校只接触过锐捷和思科的交换机和路由器。但是新买的交换机是华为系列。结果在刚开始还按照之前的旧思路进行部署,用单独的路由器做DHCP服务,比较曲折。最后仔细阅读该款交换机文档之后,发现该交换机自带DHCP服务,最后最后以一种很简单的方式解决了这个问题。

PS:其它还可以更加简单些,但是由于物理环境限制,且还缺一个两层交换机。

一、S5700S-28P-LI-AC三层交换机配置

1、设计

配置思路如下:

1)创建三个虚拟局域网(VLAN)

  • vlan 100 :绑定一个接口与上层路由器进行物理连接,并与上层路由器位于同一网段。即:192.168.1.60
  • vlan 2     :子网段,192.168.3.0/24
  • vlan 4     :子网段,192.168.2.0/24

2)  利用vlanif使得以上三个VLAN间可以互通

3)  vlan2 与 vlan4 开启DHCP服务,向子网段分配100~254段IP地址

2、设计过程

懒得写,暂时忽略。

3、设计结构

最终配置结果如下:

查看VLAN:

GG-ui-vty0-4]dis vlan
The total number of vlans is : 6
--------------------------------------------------------------------------------
U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
MP: Vlan-mapping;               ST: Vlan-stacking;
#: ProtocolTransparent-vlan;    *: Management-vlan;
--------------------------------------------------------------------------------

VID  Type    Ports                                                          
--------------------------------------------------------------------------------
1    common  
2    common  UT:GE0/0/3(D)      GE0/0/4(D)      GE0/0/5(D)      GE0/0/6(D)      
                GE0/0/7(D)      GE0/0/8(D)      GE0/0/9(D)      GE0/0/10(D)     
                GE0/0/11(D)     GE0/0/12(D)                                     
4    common  UT:GE0/0/13(D)     GE0/0/14(U)     GE0/0/15(D)     GE0/0/16(D)     
                GE0/0/17(D)     GE0/0/18(D)     GE0/0/19(D)     GE0/0/20(D)     
                GE0/0/21(D)     GE0/0/22(D)     GE0/0/23(D)     GE0/0/24(D)     
10   *common 
100  common  UT:GE0/0/1(U)                                                      
1000 common  UT:GE0/0/2(D)      GE0/0/25(D)     GE0/0/26(D)     GE0/0/27(D)     
                GE0/0/28(D)                                                     

VID  Status  Property      MAC-LRN Statistics Description      
--------------------------------------------------------------------------------
1    enable  default       enable  disable    admin_vlan                        
2    enable  default       enable  disable    VLAN 0002                         
4    enable  default       enable  disable    VLAN 0004                         
10   enable  default       enable  disable    VLAN 0010                         
100  enable  default       enable  disable    VLAN 0100                         
1000 enable  default       enable  disable    VLAN 1000

 

查看当前配置

[GG-ui-vty0-4]dis cur
!Software Version V200R007C00SPC500
#
sysname GG
#
super password level 3 cipher
#
vlan batch 2 4 10 100 1000
#
clock timezone UTC add 00:00:00
#
dhcp enable
#
vlan 1
 description admin_vlan
vlan 10
 management-vlan
#忽略部分安全信息
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password irreversible-cipher
#
interface Vlanif1
 shutdown
#
interface Vlanif2
 ip address 192.168.3.1 255.255.255.0
 dhcp select interface
 dhcp server excluded-ip-address 192.168.3.100 192.168.3.252
 dhcp server dns-list 192.168.1.1 114.114.114.114
#
interface Vlanif4
 ip address 192.168.2.1 255.255.255.0
 dhcp select interface
 dhcp server excluded-ip-address 192.168.2.100 192.168.2.253
 dhcp server dns-list 192.168.1.1 114.114.114.114
#
interface Vlanif40
#
interface Vlanif100                       
 ip address 192.168.1.60 255.255.255.0
#
interface GigabitEthernet0/0/1
 port default vlan 100
#
interface GigabitEthernet0/0/2
 port default vlan 1000
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 2
#
interface GigabitEthernet0/0/4
 port default vlan 2
#
interface GigabitEthernet0/0/5
 port default vlan 2
#
interface GigabitEthernet0/0/6
 port default vlan 2
#
interface GigabitEthernet0/0/7
 port default vlan 2
#                                         
interface GigabitEthernet0/0/8
 port default vlan 2
#
interface GigabitEthernet0/0/9
 port default vlan 2
#
interface GigabitEthernet0/0/10
 port default vlan 2
#
interface GigabitEthernet0/0/11
 port default vlan 2
#
interface GigabitEthernet0/0/12
 port default vlan 2
#
interface GigabitEthernet0/0/13
 port link-type access
 port default vlan 4
#
interface GigabitEthernet0/0/14
 port default vlan 4
#
interface GigabitEthernet0/0/15
 port default vlan 4                      
#
interface GigabitEthernet0/0/16
 port default vlan 4
#
interface GigabitEthernet0/0/17
 port default vlan 4
#
interface GigabitEthernet0/0/18
 port default vlan 4
#
interface GigabitEthernet0/0/19
 port default vlan 4
#
interface GigabitEthernet0/0/20
 port default vlan 4
#
interface GigabitEthernet0/0/21
 port default vlan 4
#
interface GigabitEthernet0/0/22
 port default vlan 4
#
interface GigabitEthernet0/0/23
 port default vlan 4                      
#
interface GigabitEthernet0/0/24
 port default vlan 4
#
interface GigabitEthernet0/0/25
 port default vlan 1000
#
interface GigabitEthernet0/0/26
 port default vlan 1000
#
interface GigabitEthernet0/0/27
 port default vlan 1000
#
interface GigabitEthernet0/0/28
 port default vlan 1000
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 192.168.1.1
#
user-interface con 0
 authentication-mode password
 set authentication password cipher $$
user-interface vty 0 4                    
 authentication-mode aaa
user-interface vty 16 20
#
return

保存配置:返回用户视图,使用save指令保存当前配置。

二、TL-ER6120路由器配置

该路由器为一款普通的路由器,设置了DHCP服务,向LAN分配192.168.1.0/24区段地址,且运行了NAT服务,提供包转换。

由于192.168.2.0/24,192.168.3.0/24两个虚拟局域网的数据包都通过192.168.1.60转发到192.168.1.1 TL-ER6120路由器。由于并未经过NAT包转换,所以仍然是192.168.2.0/24,192.168.3.0/24原始地址,无法经过192.168.1.1网关。所以需要在TL-ER6120上设置多网段NAT服务,对192.168.2.0/24,192.168.3.0/24网段地址进行NAT转换。

设置细节如下图:

 

参考链接


http://support.huawei.com/ehedex/hdx.do?docid=DOC1000081668&lang=zh&idPath=7919710%7C21782164%7C21782167%7C6691579&clientWidth=1350&browseTime=1481113432235

http://support.huawei.com/ehedex/pages/DOC1000081668DZE0811M/03/DOC1000081668DZE0811M/03/resources/pdf/quikmain_xsx7.pdf?ft=0&id=DZE0811M_03_10187

http://support.huawei.com/ehedex/pages/DOC1000081668DZE0811M/03/DOC1000081668DZE0811M/03/resources/pdf/quikcfg.pdf?ft=0&id=DZE0811M_03_10186

 

参考文件


华为路由交换由浅入深系列(十三):华为小型网络组网模型讲解(AR系列路由器+S5700交换机):

%e5%8d%8e%e4%b8%ba%e8%b7%af%e7%94%b1%e4%ba%a4%e6%8d%a2%e7%94%b1%e6%b5%85%e5%85%a5%e6%b7%b1%e7%b3%bb%e5%88%97%ef%bc%88%e5%8d%81%e4%b8%89%ef%bc%89%ef%bc%9a%e5%8d%8e%e4%b8%ba%e5%b0%8f%e5%9e%8b%e7%bd%91

华为S系列园区交换机快速配置:

%e5%8d%8e%e4%b8%bas%e7%b3%bb%e5%88%97%e5%9b%ad%e5%8c%ba%e4%ba%a4%e6%8d%a2%e6%9c%ba%e5%bf%ab%e9%80%9f%e9%85%8d%e7%bd%ae

分享到:更多 ()